TParadoxDataSet: Illegal type conversion "PChar" to "PtrRec"

Für Themen zu Datenbanken und Zugriff auf diese. Auch für Datenbankkomponenten.

Re: TParadoxDataSet: Illegal type conversion "PChar" to "Ptr

Beitragvon Ich934 » 12. Mai 2019, 12:07 Re: TParadoxDataSet: Illegal type conversion "PChar" to "Ptr

Also diese Komponente funktioniert und löst jede Menge Probleme die ich hatte. :-D Vielen Dank dafür!!! Ich hatte übrigens Build 6860 benutzt und damit keine Chance. Die neue Version geht ohne Probleme. Damit hab ich jetzt auch die mitgelieferte Version ersetzt. Der Vorteil ohne DLLs auszukommen hat schon was.

FPCUpDeluxe schau ich mir mal an. An sich klingt das sehr interessant und da ich jetzt ja wieder viel mehr mit Pascal arbeite hat das seine Vorteile.

Schöne Grüße
OS: ArchLinux, Windows 10 x64, Lazarus über fpcupdeluxe
Tipp für PostgreSQL: www.pg-forum.de
Ich934
Lazarusforum e. V.
 
Beiträge: 13
Registriert: 5. Mai 2019, 16:52
OS, Lazarus, FPC: ArchLinux, Windows mit FPCUPdeluxe (L: 2.0.2, FPC 3.0.4) | 
CPU-Target: x86_64, i386
Nach oben

Beitragvon wp_xyz » 12. Mai 2019, 18:45 Re: TParadoxDataSet: Illegal type conversion "PChar" to "Ptr

Ich934 hat geschrieben:Hm, ich habe das Package von Sourceforge und zwar über den Link aus dem Wiki (wenn ich jetzt nicht falsch lieg): http://wiki.freepascal.org/TParadoxDataSet

Das ist die alte Version... Ich habe das wiki aktualisiert. Download-Link für die aktuelle Release-Version ist https://sourceforge.net/projects/lazaru ... p/download. Die Entwickler-Version ist auf https://sourceforge.net/p/lazarus-ccr/s ... oxdataset/. Das Package ist nun auch beim Online-Package-Manager eingereicht, damit wird es aus Lazarus heraus direkt zu installieren sein (erfordert natürlich eine halbwegs aktuelle Laz-Version). Die Package-Datei wurde gegenüber der Vorgänger-Version leicht umbenannt (lazparadoxpkg statt lazparadox), damit es zusammen mit dem bisher gleichnamigen, mit Lazarus ausgelieferten TPardox installiert sein kann.

Die aktuelle Version kann
- 32bit/64bit, Windows, gtk2, qt, evtl noch mehr
- keine externe Lib nötig
- BLOBs, Bookmarks, Filtern, Textkodierung nach UTF8 umwandeln
- aber: kann nur Lesen, keine Indexe, kein Sortieren.

[NACHTRAG]
Das Package kann nun auch in Online-Package-Manager installiert werden.
wp_xyz
 
Beiträge: 2930
Registriert: 8. Apr 2011, 09:01

• Themenende •
Vorherige

Zurück zu Datenbanken



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

porpoises-institution
accuracy-worried