[gelöst] Laz1.9 unter Mint 18.2 und Crosscompiling

Für Installationen unter Linux-Systemen

Re: [gelöst] Laz1.9 unter Mint 18.2 und Crosscompiling

Beitragvon thosch » 16. Jul 2017, 20:24 Re: [gelöst] Laz1.9 unter Mint 18.2 und Crosscompiling

Habe soeben das Prjekt fpcupdeluxe übersetzt und den Installer gleich mal getestet.

Ich habe ausschließlich Lazarus für Windows Version 1.6.4 in Wine installiert, dann das Verzeichnis in der fpcupdeluxe.zip Datei nach Lazarus kopiert. Dann Lazarus gestartet, das Projekt geladen und übersetzt und dann mit Default-Einstellungen gestartet außer

CPU x86_64

OS Linux.

Ich erhalte dabei einen schwerwiegenden Fehler im Programm git.exe

Folgende Fehlerdetails:

Unhandled exception: page fault on write access to 0x00000000 in 32-bit code (0x00576c80).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:00576c80 ESP:0089f870 EBP:00000047 EFLAGS:00010256( R- -- I Z-A-P- )
EAX:00000000 EBX:00000000 ECX:0089f870 EDX:00000000
ESI:00000000 EDI:008a04b0
Stack dump:
0x0089f870: 0000007c 00000001 0089f89c 000003fe
0x0089f880: 0089f898 00000000 0000000a 00000000
0x0089f890: 31323532 00000000 00000008 00000000
0x0089f8a0: 00000000 00000030 00000017 61ecf6c5
0x0089f8b0: 00000001 0089f8ec 00000000 00000000
0x0089f8c0: 00000000 ffffffff ffffffff 0089f954
Backtrace:
=>0 0x00576c80 in git (+0x176c80) (0x00000047)
0x00576c80: movw %dx,0x0(%esi,%eax,2)
Modules:
Module Address Debug info Name (43 modules)
PE 400000- 692000 Export git
PE 61ec0000-61eea000 Deferred libintl-8
PE 63080000-6309e000 Deferred zlib1
PE 64b40000-64b57000 Deferred libwinpthread-1
PE 66200000-6630b000 Deferred libiconv-2
PE 68cc0000-68ccc000 Deferred libssp-0
PE 69340000-6938d000 Deferred libpcre-1
PE 6eb40000-6eb63000 Deferred libgcc_s_dw2-1
ELF 7b800000-7ba5f000 Deferred kernel32<elf>
\-PE 7b810000-7ba5f000 \ kernel32
ELF 7bc00000-7bce5000 Deferred ntdll<elf>
\-PE 7bc10000-7bce5000 \ ntdll
ELF 7bf00000-7bf03000 Deferred <wine-loader>
ELF 7e536000-7e559000 Deferred imm32<elf>
\-PE 7e540000-7e559000 \ imm32
ELF 7e654000-7e67e000 Deferred libexpat.so.1
ELF 7e67e000-7e6c0000 Deferred libfontconfig.so.1
ELF 7e6c0000-7e6ec000 Deferred libpng12.so.0
ELF 7e6ec000-7e709000 Deferred libz.so.1
ELF 7e709000-7e7ba000 Deferred libfreetype.so.6
ELF 7e810000-7e848000 Deferred ws2_32<elf>
\-PE 7e820000-7e848000 \ ws2_32
ELF 7e848000-7e95a000 Deferred gdi32<elf>
\-PE 7e850000-7e95a000 \ gdi32
ELF 7e95a000-7eaa7000 Deferred user32<elf>
\-PE 7e970000-7eaa7000 \ user32
ELF 7eaa7000-7eb5d000 Deferred msvcrt<elf>
\-PE 7eac0000-7eb5d000 \ msvcrt
ELF 7eb5d000-7ebd2000 Deferred advapi32<elf>
\-PE 7eb70000-7ebd2000 \ advapi32
ELF 7ebd2000-7ebe0000 Deferred libnss_files.so.2
ELF 7ebe0000-7ebed000 Deferred libnss_nis.so.2
ELF 7ebed000-7ec08000 Deferred libnsl.so.1
ELF 7ec08000-7ec12000 Deferred libnss_compat.so.2
ELF 7ef84000-7efd0000 Deferred libm.so.6
ELF 7efe7000-7f000000 Deferred version<elf>
\-PE 7eff0000-7f000000 \ version
ELF f7361000-f7366000 Deferred libdl.so.2
ELF f7366000-f74e3000 Deferred libc.so.6
ELF f74e4000-f7500000 Deferred libpthread.so.0
ELF f7530000-f76e7000 Dwarf libwine.so.1
ELF f76e9000-f770c000 Deferred ld-linux.so.2
ELF f770e000-f770f000 Deferred [vdso].so
Threads:
process tid prio (all id:s are in hex)
0000000e services.exe
0000001e 0
0000001d 0
00000014 0
00000010 0
0000000f 0
00000012 winedevice.exe
0000001c 0
00000019 0
00000018 0
00000013 0
0000001a plugplay.exe
00000020 0
0000001f 0
0000001b 0
00000021 explorer.exe
00000027 0
00000026 0
00000025 0
00000022 0
0000002b lazarus.exe
00000043 0
00000041 0
0000002c 0
00000031 TOTALCMD.EXE
00000044 -1
00000042 0
0000003e -1
0000003c 0
00000037 0
00000036 0
00000035 -1
00000034 -1
00000033 -2
00000032 0
00000047 gdb.exe
00000017 0
00000045 0
00000029 fpcupdeluxe-i386-win32.exe
00000028 0
00000023 git.exe
00000030 0
00000038 (D) C:\fpcupdeluxe\fpcbootstrap\git\mingw32\bin\git.exe
0000000d 0 <==
System information:
Wine build: wine-1.7.50-126-g6056a3f
Platform: i386
Host system: Linux
Host version: 4.2.6-64


Ich habe das unter WINE gemacht. Knoppix 7.6

Werde später den gleichen Versuch unter echtem Windows ( Windows 10 ) durchführen.

Totalcmd.exe Version 8.51a war während des Programmlaufes geöffnet. Im Wine. Ich bin positiv überrascht, dass der im Wine läuft.

Lazarus 64 Bit funktioniert nicht im Wine, ich habe die 32 Bit Version installiert, meine CPU ist 64 Bittig. Knoppix stellt sich automatisch auf die Wortbreite des Prozessors ein. Zumindest in meinem Live System.

Was muss oder kann ich noch tun, um die Installation abzuschließen.

Eine Fehlermeldung in Richtung "es fehlen die Pakete X, Y, Z, ..." wäre mir verständlicher, da ich ja nur die Windows Version von Lazarus installiert habe. Fehlende Linux Bibliotheken und Unitversionen würde ich da verstehen, aber das oben aufgeführte Fehlerprotokoll??????

.
thosch
 
Beiträge: 46
Registriert: 10. Jul 2017, 19:32

Beitragvon Mathias » 16. Jul 2017, 21:32 Re: [gelöst] Laz1.9 unter Mint 18.2 und Crosscompiling

Willst du ein kompiliertes fpcupdeluxe für Linux, somit musst du das normale Lazarus nicht unter Linux installieren. ?

Mit dieser Procedure kannst noch gucken, ob deine Anwendung für die richtige Plattform kompiliert wurde.
Code: Alles auswählen
procedure TForm1.Button1Click(Sender: TObject);
begin
  ShowMessage('OS: '+ {$I %FPCTARGETOS%}+'  CPU:'+ {$I %FPCTARGETCPU%});
end;
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot
Mathias
 
Beiträge: 2877
Registriert: 2. Jan 2014, 17:21
Wohnort: Schweiz
OS, Lazarus, FPC: Linux (die neusten Trunc) | 
CPU-Target: 64Bit
Nach oben

Beitragvon thosch » 17. Jul 2017, 08:13 Re: [gelöst] Laz1.9 unter Mint 18.2 und Crosscompiling

Mathias hat geschrieben:Willst du ein kompiliertes fpcupdeluxe für Linux, somit musst du das normale Lazarus nicht unter Linux installieren. ?


Unter Windows wird fpcupdeluxe auch fehlerfrei übersetzt, zumindest mit Lazarus für Win32. Das Programm Git ist aber in Windows nicht vorinstalliert. Ich erhalte folgendes Fehlerprotokoll:


Mathias hat geschrieben:Mit dieser Procedure kannst noch gucken, ob deine Anwendung für die richtige Plattform kompiliert wurde.
Code: Alles auswählen
procedure TForm1.Button1Click(Sender: TObject);
begin
  ShowMessage('OS: '+ {$I %FPCTARGETOS%}+'  CPU:'+ {$I %FPCTARGETCPU%});
end;


Danke für diesen Hinweis!

Ich habe nun unter native Windows das Programm ausgeführt!

Ich erhalte folgendes Fehlerprotokoll:

FPCUPdeluxe V1.4.0l base fpcup027 (20170616) for i386-win32

Going to install a cross-compiler from available sources.
Building compiler for linux-x86_64.
FPCUP(deluxe) is starting up.

Binutils/make dir: C:\fpcupdeluxe\fpcbootstrap
Bootstrap dir: C:\fpcupdeluxe\fpcbootstrap
Please stand back and enjoy !

fpcupdeluxe: info: 17.07.2017 08:57:24: fpcup027 (20170616) started.
fpcupdeluxe: info: Windows major version: 10
fpcupdeluxe: info: Windows minor version: 0
fpcupdeluxe: info: Windows build number: 14393
fpcupdeluxe: WARNING: FPCCrossInstaller (CheckAndGetTools): No OpenSLL library files available. Going to download them
fpcupdeluxe: info: Native downloader: Getting openssl-1.0.2j-i386-win32.zip from indy.fulgan.com/SSL/
fpcupdeluxe: info: TNormalUnzipper: Going to extract files from C:\Users\winuser\AppData\Local\Temp\TMP00000.tmp.zip into C:\lazarus\fpcupdeluxe-master\deluxebin\
fpcupdeluxe: info: Extracting libeay32.dll. #1 out of #2
fpcupdeluxe: info: Extracting ssleay32.dll. #2 out of #2
fpcupdeluxe: info: FPCCrossInstaller (DownloadOpenSSL): OpenSLL download and unpacking ok.
fpcupdeluxe: info: Native downloader: Getting patch.exe from svn.freepascal.org/svn/fpcbuild/tags/release_3_0_2/install/binw32/
fpcupdeluxe: info: Native downloader: Getting patch.exe.manifest from svn.freepascal.org/svn/fpcbuild/tags/release_3_0_2/install/binw32/
fpcupdeluxe: info: Native downloader: Getting 7za920.zip from downloads.sourceforge.net/project/sevenzip/7-Zip/9.20/
fpcupdeluxe: info: TNormalUnzipper: Going to extract files from C:\fpcupdeluxe\fpcbootstrap\7Zip\7za920.zip into C:\fpcupdeluxe\fpcbootstrap\7Zip\
fpcupdeluxe: info: Extracting 7za.exe. #1 out of #1
fpcupdeluxe: info: Native downloader: Getting unrar-3.4.3-bin.zip from downloads.sourceforge.net/project/gnuwin32/unrar/3.4.3/
fpcupdeluxe: info: TNormalUnzipper: Going to extract files from C:\fpcupdeluxe\fpcbootstrap\unrar\unrar-3.4.3-bin.zip into C:\fpcupdeluxe\fpcbootstrap\unrar\
fpcupdeluxe: info: Extracted #5 files out of #69
fpcupdeluxe: info: Extracted #10 files out of #69
fpcupdeluxe: info: Extracted #15 files out of #69
fpcupdeluxe: info: Extracted #20 files out of #69
fpcupdeluxe: info: Extracted #25 files out of #69
fpcupdeluxe: info: Extracted #30 files out of #69
fpcupdeluxe: info: Extracted #35 files out of #69
fpcupdeluxe: info: Extracted #40 files out of #69
fpcupdeluxe: info: Extracted #45 files out of #69
fpcupdeluxe: info: Extracted #50 files out of #69
fpcupdeluxe: info: Extracted #55 files out of #69
fpcupdeluxe: info: Extracted #60 files out of #69
fpcupdeluxe: info: Extracted #65 files out of #69
fpcupdeluxe: info: FPCCrossInstaller (GetFile): GIT not found. Download it (may take time) from https://github.com/newpascal/fpcupdelux ... Git-2.13.2
fpcupdeluxe: info: Native downloader: Getting git32.7z from github.com/newpascal/fpcupdeluxe/releases/download/Git-2.13.2/
fpcupdeluxe: info: FPCCrossInstaller (GetFile): GIT download ready: unpacking (may take time).
Executing: C:\fpcupdeluxe\fpcbootstrap\\7Zip\7za.exe "x" "-oC:\fpcupdeluxe\fpcbootstrap\git\" "C:\fpcupdeluxe\fpcbootstrap\git\git32.7z" (working dir: )

7-Zip (A) 9.20 Copyright (c) 1999-2010 Igor Pavlov 2010-11-18

Processing archive: C:\fpcupdeluxe\fpcbootstrap\git\git32.7z


Everything is Ok

Folders: 699
Files: 5631
Size: 249735946
Compressed: 36731476
fpcupdeluxe: WARNING: FPCCrossInstaller (FindSVNSubDirs): Could not find svn executable in or under C:\fpcupdeluxe\fpcbootstrap\svn\
fpcupdeluxe: info: FPCCrossInstaller (FindSVNSubDirs): Going to download SVN
fpcupdeluxe: info: Native downloader: Getting Apache-Subversion-1.9.5.zip from http://www.visualsvn.com/files/
fpcupdeluxe: info: TNormalUnzipper: Going to extract files from C:\Users\winuser\AppData\Local\Temp\TMP00000.tmp.zip into C:\fpcupdeluxe\fpcbootstrap\svn\
fpcupdeluxe: info: Extracting svn.exe. #1 out of #28
fpcupdeluxe: info: Extracting svnadmin.exe. #2 out of #28
fpcupdeluxe: info: Extracting svnbench.exe. #3 out of #28
fpcupdeluxe: info: Extracting svndumpfilter.exe. #4 out of #28
fpcupdeluxe: info: Extracting svnfsfs.exe. #5 out of #28
fpcupdeluxe: info: Extracting svnlook.exe. #6 out of #28
fpcupdeluxe: info: Extracting svnserve.exe. #7 out of #28
fpcupdeluxe: info: Extracting svnsync.exe. #8 out of #28
fpcupdeluxe: info: Extracting svnversion.exe. #9 out of #28
fpcupdeluxe: info: Extracting svnmucc.exe. #10 out of #28
fpcupdeluxe: info: Extracting svnrdump.exe. #11 out of #28
fpcupdeluxe: info: Extracting libsvn_client-1.dll. #12 out of #28
fpcupdeluxe: info: Extracting libsvn_delta-1.dll. #13 out of #28
fpcupdeluxe: info: Extracting libsvn_diff-1.dll. #14 out of #28
fpcupdeluxe: info: Extracting libsvn_fs-1.dll. #15 out of #28
fpcupdeluxe: info: Extracting libsvn_ra-1.dll. #16 out of #28
fpcupdeluxe: info: Extracting libsvn_repos-1.dll. #17 out of #28
fpcupdeluxe: info: Extracting libsvn_subr-1.dll. #18 out of #28
fpcupdeluxe: info: Extracting libsvn_wc-1.dll. #19 out of #28
fpcupdeluxe: info: Extracting libapr-1.dll. #20 out of #28
fpcupdeluxe: info: Extracting libaprutil-1.dll. #21 out of #28
fpcupdeluxe: info: Extracting msvcp100.dll. #22 out of #28
fpcupdeluxe: info: Extracting msvcr100.dll. #23 out of #28
fpcupdeluxe: info: Extracting APR License.txt. #24 out of #28
fpcupdeluxe: info: Extracting APR Util License.txt. #25 out of #28
fpcupdeluxe: info: Extracting OpenSSL License.txt. #26 out of #28
fpcupdeluxe: info: Extracting Subversion License.txt. #27 out of #28
fpcupdeluxe: info: Extracting ZLib License.txt. #28 out of #28
fpcupdeluxe: info: FPCCrossInstaller (DownloadSVN): SVN download and unpacking ok. Not going to search SVN client itself in C:\fpcupdeluxe\fpcbootstrap\svn\
fpcupdeluxe: info: FPCCrossInstaller (BuildModule: FPC): Building module FPC...
fpcupdeluxe: ERROR: Tried to get FPC version from version.pas, but no version.pas found
fpcupdeluxe: info: FPCCrossInstaller (BuildModule: FPC): We have a FPC source (@ C:\fpcupdeluxe\fpcsrc) with version: 0.0.0
fpcupdeluxe: ERROR: Tried to get required bootstrap compiler version from Makefile.fpc, but no Makefile.fpc found
fpcupdeluxe: ERROR: Tried to get required bootstrap compiler version from Makefile.fpc, but no Makefile.fpc found
fpcupdeluxe: ERROR: Tried to get FPC version from version.pas, but no version.pas found
fpcupdeluxe: ERROR: FPCCrossInstaller (BuildModule: FPC): Could not determine required bootstrap compiler version. Should not happen. Aborting.
fpcupdeluxe: ERROR: Sequencer (FPCBuildOnly): Failure running fpcupdeluxe: error executing sequence FPCBuildOnly; line: 2, param: FPC
fpcupdeluxe: ERROR: Sequencer (Only): Failure running fpcupdeluxe: error executing sequence Only; line: 2, param: FPCBuildOnly


ERROR: Fpcupdeluxe fatal error !
Building cross-tools failed ... ??? ... aborting.



Git ist nicht auf meinem System installiert. Windows 10

Wieso aber dann diese Meldung hier?:
Processing archive: C:\fpcupdeluxe\fpcbootstrap\git\git32.7z


Everything is Ok


svn ist meines Wissens nach auch nicht installiert.

Ich glaube, nicht eine für Linux vorcompilierte fpcupdeluxe Version ist es, was ich brauche, sondern die FPC- und Lazarus Units plus Compiler mit den richtigen Einstellungen ist es was ich brauche. Der Compiler muss dann unter Windows ausführbar sein und bleiben, aber ich brauche dann auch die Units für Linux. So wie das Codethyphoon macht. Und wie das auch bei GO32 gemacht wird, wo dann der FPC-Compiler für diese Plattform im /fpc Verzeichnis installiert wird.

Der fpcupdeluxe Installer hat mir einen Ordner gleichen Namens angelegt, mit allen Tools.

Wo gibt es dazu verständlich formulierte Anleitungen für die Benutzung?

.
thosch
 
Beiträge: 46
Registriert: 10. Jul 2017, 19:32

Beitragvon shokwave » 17. Jul 2017, 16:08 Re: [gelöst] Laz1.9 unter Mint 18.2 und Crosscompiling

fpcupdeluxe: info: FPCCrossInstaller (BuildModule: FPC): We have a FPC source (@ C:\fpcupdeluxe\fpcsrc) with version: 0.0.0

Für mich liest sich das, als ob er unter C:\fpcupdeluxe\fpcsrc den Quellcode vom FPC sucht und ihn nicht findet. Hast du vor dem CossInstall eine "normale" Installation gemacht? Diese braucht er als "Basis".
mfg Ingo
shokwave
 
Beiträge: 407
Registriert: 15. Nov 2007, 16:58
Wohnort: Rudolstadt
OS, Lazarus, FPC: Win10 (L 1.6 FPC 3.0.0) | 
CPU-Target: i386,x64
Nach oben

Beitragvon thosch » 18. Jul 2017, 10:25 Re: [gelöst] Laz1.9 unter Mint 18.2 und Crosscompiling

Habe soeben Linux Mint auf SD Karte installiert. Dachte zuerst wegen Auskunft von Rufus, es sei nur der Installer. Ist es aber nicht, es ist ein Live System.

2 Probleme:

- Amerikanische Tastatur voreingestellt. Geht für mich gar nicht!

- Lazarus lässt sich mit dem grafischen Softwareinstaller auswählen und installieren.

Nur finde ich nach der Installation Lazarus nicht.

Nein, ich bleibe beim guten altbewährten Konoppix.

Der Linux Mint Desktop ist mir zu minimalistisch. Ich brauche meine App-Icons auf der Arbeotsfläche, mein Startmenü mit allen installierten Apps, die in sinnvollen Rubriken geordnet sind. Nach Lazarus-Installation mit dem Paketinstaller gab es kein Untermenü "Entwicklung". Das installierte Lazarus ist einfach nicht auffindbar und auch im Terminal "lazarus" aufrufen funzt nicht.

.
thosch
 
Beiträge: 46
Registriert: 10. Jul 2017, 19:32

Beitragvon Mathias » 18. Jul 2017, 17:05 Re: [gelöst] Laz1.9 unter Mint 18.2 und Crosscompiling

Habe soeben Linux Mint auf SD Karte installiert. Dachte zuerst wegen Auskunft von Rufus, es sei nur der Installer. Ist es aber nicht, es ist ein Live System.

Ein Mint-Images beinhaltet beides, bei einem Start ab Stick, läuft Mint als Live-Version, dort hat es aber ein Icon "Mint installieren".

- Amerikanische Tastatur voreingestellt. Geht für mich gar nicht!

Bei der Installation kann man dann einen Tastatur-Treiber nach Wahl nehmen.

- Lazarus lässt sich mit dem grafischen Softwareinstaller auswählen und installieren.

Bei der Live-Version, ist die Installation nach einem Neustart wieder weg. Man muss sich vorstellen, wie wen Mint ab einer CD-ROM läuft.

Nach Lazarus-Installation mit dem Paketinstaller gab es kein Untermenü "Entwicklung".

Normalerweise bekommt man dieses.
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot
Mathias
 
Beiträge: 2877
Registriert: 2. Jan 2014, 17:21
Wohnort: Schweiz
OS, Lazarus, FPC: Linux (die neusten Trunc) | 
CPU-Target: 64Bit
Nach oben

• Themenende •
Vorherige

Zurück zu Linux



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

porpoises-institution
accuracy-worried