Unzuverlässige USB Ports?

Für sonstige Unterhaltungen, welche nicht direkt mit Lazarus zu tun haben
theo
Beiträge: 8299
Registriert: Mo 11. Sep 2006, 19:01

Re: Unzuverlässige USB Ports?

Beitrag von theo »

Christian hat geschrieben:Mhm hier komm ich auch an meine Grenzen.

Ich auch. :roll:

Ich möchte allen die geantwortet haben recht herzlich danken.

Ich habe es aufgegeben das Problem verstehen zu wollen
Es gibt wohl auch im Bereich der "Logik" eine Ansammlung von Umständen die am Ende ohne massiven Analyseaufwand undurchdringlich sind.
CPU? BIOS? BIOS-CPU? CPU-BS? Beim Betriebssystem laufen dann zig. Sachen ab und dann noch Suspend-Resume, Power Management etc.
Oder ist es doch nur das eine Gerät (WLan Stick) welches nicht richtig will?
Oder stören sich die USB Geräte etwa gegenseitig in einer bestimmten Konstellation?
Oder habe ich doch beim Lüfter Einbau etwas am Board vergurkt?

Für mich ist es jetzt OK.
Habe den WLan Stick hinten an den USB3 Port gesteckt und da läuft er stabil (obwohl eigentlich nur ein 2.0 Stick).
Die externe USB3 HD läuft jetzt an USB 2.0 problemlos (am selben Port an dem WLan nicht läuft).
Als Backup und Multimedia Medium ist das nicht so schlimm. Der zweite USB3 Port ist durch den WLan Stick leider Formfaktor-mässig blockiert.

Dafür habe ich vorne neben dem Maus-Dongle noch einen USB 2.0 Anschluss frei für Sticks.

Ist zwar doof, aber damit kann ich leben. 8)

Danke.

EDIT: Das mit dem Formfaktor hat sich erledigt. Betreibe nun WLan und Externe HD an USB3. So ist das OK.

Benutzeravatar
af0815
Lazarusforum e. V.
Beiträge: 4106
Registriert: So 7. Jan 2007, 10:20
OS, Lazarus, FPC: FPC fixes Lazarus fixes per fpcupdeluxe (win,linux,raspi)
CPU-Target: 32Bit (64Bit)
Wohnort: Niederösterreich
Kontaktdaten:

Re: Unzuverlässige USB Ports?

Beitrag von af0815 »

theo hat geschrieben:Oder ist es doch nur das eine Gerät (WLan Stick) welches nicht richtig will?


Laut dem, was ich im Inet gefunden habe, hat bei manche Chipsets (lt. deinen Logmeldungen) der WLan per USB ein 'gewisses' Eigenleben. Die Probleme, ähnlich wie du sie hast, sind öfters auf einigen Linuxvarianten aufgetreten. Nachdem manche Lösungen IMHO 'esoterisch' erschienen sind und ich sie nicht nachprüfen kann, habe ich meine vorlauten Finger zurückgehalten.
Blöd kann man ruhig sein, nur zu Helfen muss man sich wissen (oder nachsehen in LazInfos/LazSnippets).

theo
Beiträge: 8299
Registriert: Mo 11. Sep 2006, 19:01

Re: Unzuverlässige USB Ports?

Beitrag von theo »

af0815 hat geschrieben:
theo hat geschrieben:Oder ist es doch nur das eine Gerät (WLan Stick) welches nicht richtig will?


Laut dem, was ich im Inet gefunden habe, hat bei manche Chipsets (lt. deinen Logmeldungen) der WLan per USB ein 'gewisses' Eigenleben. Die Probleme, ähnlich wie du sie hast, sind öfters auf einigen Linuxvarianten aufgetreten. Nachdem manche Lösungen IMHO 'esoterisch' erschienen sind und ich sie nicht nachprüfen kann, habe ich meine vorlauten Finger zurückgehalten.


Ja, ich habe der Sache natürlich auch noch "nachgegoogelt".
Ist halt schwierig. Erzählen kann man viel - glauben auch.
Den einen überzeugenden Hinweis habe ich nicht gefunden.
Es bleibt etwas merkwürdig., aber wie gesagt, ich kann mit der Situation jetzt leben.

Danke für deinen Beistand. :)

pluto
Lazarusforum e. V.
Beiträge: 7068
Registriert: So 19. Nov 2006, 12:06
OS, Lazarus, FPC: Linux Mint 19.3
CPU-Target: AMD
Wohnort: Oldenburg(Oldenburg)

Re: Unzuverlässige USB Ports?

Beitrag von pluto »

Starte mal von einer Live DVD ob es dann besser ist.

Ich hatte mal ein Problem mit einem Uart, auf mein PC läuft dieser Problemlos und auf dem Banana PI gar nicht. Ein Kernel Update brachte die Lösung.
in deinem Fall ist das wohl etwas anders.

Aber So kannst du sehen, ob die Aktuelle Ubuntu Version damit ebenfalls Probleme hat.

Wie sind die Hinteren USB Anschlüssen angeschlossen? Die müssen doch an einem USB Host angeschlossen sein, vielleicht wird dieser von der neuen CPU anders angesteuert.
MFG
Michael Springwald

pluto
Lazarusforum e. V.
Beiträge: 7068
Registriert: So 19. Nov 2006, 12:06
OS, Lazarus, FPC: Linux Mint 19.3
CPU-Target: AMD
Wohnort: Oldenburg(Oldenburg)

Re: Unzuverlässige USB Ports?

Beitrag von pluto »

Sag mal: hast du das Netzteil vom PC ebenfalls angepasst bzw. ausgetauscht?

Die neue CPU braucht doch bestimmt mehr Strom. Vielleicht liefert das Netzteil zu Wenig strom.
MFG
Michael Springwald

theo
Beiträge: 8299
Registriert: Mo 11. Sep 2006, 19:01

Re: Unzuverlässige USB Ports?

Beitrag von theo »

pluto hat geschrieben:Die neue CPU braucht doch bestimmt mehr Strom. Vielleicht liefert das Netzteil zu Wenig strom.


Nein, im Gegenteil. Das war mit ein Grund, warum ich die neue CPU gekauft habe.
Die neue hat weniger Verlustleistung (TDP) als die alte (55 W statt 65 W).

Alt:
http://ark.intel.com/de/products/53492/ ... e-3_00-GHz
Neu:
http://ark.intel.com/de/products/65690/ ... e-3_40-GHz

Aber danke für deine Antwort.

pluto
Lazarusforum e. V.
Beiträge: 7068
Registriert: So 19. Nov 2006, 12:06
OS, Lazarus, FPC: Linux Mint 19.3
CPU-Target: AMD
Wohnort: Oldenburg(Oldenburg)

Re: Unzuverlässige USB Ports?

Beitrag von pluto »

Vielleicht hast du beim Einbau der neuen CPU, irgendein Kabel gelockert das für die Hinteren USB Ports Notwendig ist?
MFG
Michael Springwald

theo
Beiträge: 8299
Registriert: Mo 11. Sep 2006, 19:01

Re: Unzuverlässige USB Ports?

Beitrag von theo »

pluto hat geschrieben:Vielleicht hast du beim Einbau der neuen CPU, irgendein Kabel gelockert das für die Hinteren USB Ports Notwendig ist?

Das ist alles auf der Platine verlötet. Habe doch hier das Schema gepostet: viewtopic.php?p=81859#p81859

pluto
Lazarusforum e. V.
Beiträge: 7068
Registriert: So 19. Nov 2006, 12:06
OS, Lazarus, FPC: Linux Mint 19.3
CPU-Target: AMD
Wohnort: Oldenburg(Oldenburg)

Re: Unzuverlässige USB Ports?

Beitrag von pluto »

Mein Letzter Tipp wäre:
Schließt die Geräte mal über ein Aktiven USB HUB.
Wichtig ist nur, dass das Netzteil vom USB HUB genügend Strom Liefert.
MFG
Michael Springwald

theo
Beiträge: 8299
Registriert: Mo 11. Sep 2006, 19:01

Re: Unzuverlässige USB Ports?

Beitrag von theo »

pluto hat geschrieben:Mein Letzter Tipp wäre:
Schließt die Geräte mal über ein Aktiven USB HUB.
Wichtig ist nur, dass das Netzteil vom USB HUB genügend Strom Liefert.

Am Strom liegt es nicht. Das Barebone Netzteil könnte auch einen i7 und zusätzlich noch eine separate Grafikkarte speisen.
Ich glaube es ist eher ein Problem von OpenSUSE im Bereich Energieverwaltung oder so.
Oder ich schau nochmal ins BIOS Setup. Das hat sich natürlich schon gemeldet nach dem Einbau der neuen CPU, um die Einstellungen zu bestätigen.
Ich schaue bei Gelegenheit noch, was "EHCI Hand-Off" im BIOS bewirkt.

Aber ist schon OK, es funktioniert ja im Moment alles, soweit ich es brauche.

pluto
Lazarusforum e. V.
Beiträge: 7068
Registriert: So 19. Nov 2006, 12:06
OS, Lazarus, FPC: Linux Mint 19.3
CPU-Target: AMD
Wohnort: Oldenburg(Oldenburg)

Re: Unzuverlässige USB Ports?

Beitrag von pluto »

Mir ging es nicht nur um den Strom. Ein USB-HUB kann einen gewissen Effekt haben.

Hast du das mal mit der Live System Ausprobiert?
MFG
Michael Springwald

theo
Beiträge: 8299
Registriert: Mo 11. Sep 2006, 19:01

Re: Unzuverlässige USB Ports?

Beitrag von theo »

pluto hat geschrieben:Hast du das mal mit der Live System Ausprobiert?


Nein, das hat sich nicht ergeben, weil die neue OpenSUSE Version das nicht mehr anbietet.
https://software.opensuse.org/421/de

pluto
Lazarusforum e. V.
Beiträge: 7068
Registriert: So 19. Nov 2006, 12:06
OS, Lazarus, FPC: Linux Mint 19.3
CPU-Target: AMD
Wohnort: Oldenburg(Oldenburg)

Re: Unzuverlässige USB Ports?

Beitrag von pluto »

Ich habe mal jemand dein Problem beschrieben:
Er meint das ist bei Intel CPU ein Typisches Problem, wenn die PINS nicht richtig ausgerichtet sind.
Die CPU sitzt nicht richtig im Sockel.

Sein Tipp: Schau dir die PINS von der CPU genau an und richte sie gegebenfalls aus.
MFG
Michael Springwald

theo
Beiträge: 8299
Registriert: Mo 11. Sep 2006, 19:01

Re: Unzuverlässige USB Ports?

Beitrag von theo »

pluto hat geschrieben:Sein Tipp: Schau dir die PINS von der CPU genau an und richte sie gegebenfalls aus.

Und wie soll das gehen?
Man legt die CPU bei der Kerbe ein, und dann drückt man den Deckel drauf.
Viele Möglichkeiten hat man da eigentlich nicht, oder?

Hab eigentlich keine Lust, nur so zu ausprobieren die Wärmeleitpaste zu killen.

marcov
Beiträge: 1068
Registriert: Di 5. Aug 2008, 09:37
OS, Lazarus, FPC: Windows ,Linux,FreeBSD,Dos (L trunk FPC trunk)
CPU-Target: 32/64,PPC(+64), ARM
Wohnort: Eindhoven (Niederlande)

Re: Unzuverlässige USB Ports?

Beitrag von marcov »

Ist der ATX 12V Konnector im mitten angeschlossen ?

Antworten