Leerzeichen im Pfad - falsche Parameter bei AVR embedded

Für Fehler in Lazarus, um diese von anderen verifizieren zu lassen.

Re: Leerzeichen im Pfad - falsche Parameter bei AVR embedded

Beitragvon MacWomble » 16. Feb 2019, 09:38 Re: Leerzeichen im Pfad - falsche Parameter bei AVR embedded

Die Funktion ist aber schon betagt: http://forum.lazarus.freepascal.org/ind ... c=16950.15 (5. Beitrag)
Alle sagten, dass es unmöglich sei - bis einer kam und es einfach gemacht hat.
MacWomble
Lazarusforum e. V.
 
Beiträge: 877
Registriert: 17. Apr 2008, 00:59
Wohnort: Freiburg
OS, Lazarus, FPC: Mint 19.2 Cinnamon / CodeTyphon LAB 7.0 v. 03.11.2019/ FP 3.3.1 Rev 43346 | 
CPU-Target: Intel i7 64/32 Bit
Nach oben

Beitragvon Timm Thaler » 16. Feb 2019, 13:50 Re: Leerzeichen im Pfad - falsche Parameter bei AVR embedded

af0815 hat geschrieben:Geil, die maybequoted muss ich mir ansehen.


Das ist ein For-Schleife, die den String auf unerlaubte Zeichen durchsucht und wenn diese auftauchen den String in Anführungszeichen setzt. Allerdings steht ein Leerzeichen nicht in der Liste der unerlaubten Zeichen. Muss heut abend mal probieren ob es geht.
Timm Thaler
 
Beiträge: 985
Registriert: 20. Mär 2016, 22:14
OS, Lazarus, FPC: Win7-64bit Laz1.9.0 FPC3.1.1 für Win, RPi, AVR embedded | 
CPU-Target: Raspberry Pi 3
Nach oben

Beitragvon Timm Thaler » 17. Feb 2019, 00:22 Re: Leerzeichen im Pfad - falsche Parameter bei AVR embedded

Hab den neuen Trunk eingespielt: Funktioniert jetzt wieder mit Leerzeichen.
Timm Thaler
 
Beiträge: 985
Registriert: 20. Mär 2016, 22:14
OS, Lazarus, FPC: Win7-64bit Laz1.9.0 FPC3.1.1 für Win, RPi, AVR embedded | 
CPU-Target: Raspberry Pi 3
Nach oben

• Themenende •
Vorherige

Zurück zu Lazarus - Bugs



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

porpoises-institution
accuracy-worried