Fehler bei der installation der Inet Komponente

Für Installationen unter Windows

Fehler bei der installation der Inet Komponente

Beitragvon sebi099 » 23. Mär 2015, 16:25 Fehler bei der installation der Inet Komponente

Hallo zusammen,


ich bin Einsteiger in Sachen Lazarus und habe folgendes Problem:

Wenn ich versuche die Inet Komponente zu installieren bekomme ich folgende Fehlermeldungen und das Compilieren bricht ab.

C:\lazarus\components\lnet\lib\lnetssl.pp(214,24) Warning: Symbol "GetConnected" is deprecated
C:\lazarus\components\lnet\lib\lnetssl.pp(534,26) Error: Identifier not found "OPENSSLaddallalgorithms"
C:\lazarus\components\lnet\lib\lnetssl.pp(638) Fatal: There were 1 errors compiling module, stopping

hat jemand solch eine fehlermeldung bereits gehabt?

P. S. es ist die Trunk Version der Inet Komponente, da ich eine höhere Version als 0.6.5 benötige.

Wenn ich das Projekt, welches ich bearbeiten möchte dann öffne, erscheint folgende Fehlermeldung:


Kann die komponentenklasse TLTCPComponent nicht finden
Sie ist nicht mittels RegisterClass registriert und keine lfm wurde gefunden.


Ich hoffe jemand kann mir als Neuling dabei helfen.



Mfg Sebastian
sebi099
 
Beiträge: 3
Registriert: 23. Mär 2015, 16:18

Beitragvon theo » 23. Mär 2015, 16:56 Re: Fehler bei der installation der Inet Komponente

Deine Freepascal Version ist zu alt für deine lnet Version.
Die gesuchte Prozedur ist erst 11 Monate alt.

http://svn.freepascal.org/cgi-bin/viewv ... 8&r2=27523

Also entweder FPC upgraden oder lnet downgraden.
theo
 
Beiträge: 8193
Registriert: 11. Sep 2006, 18:01

Beitragvon sebi099 » 23. Mär 2015, 17:19 Re: Fehler bei der installation der Inet Komponente

Ich nutze 2.6.4, diese ist doch von 11/2014.....
sebi099
 
Beiträge: 3
Registriert: 23. Mär 2015, 16:18

Beitragvon sebi099 » 23. Mär 2015, 17:28 Re: Fehler bei der installation der Inet Komponente

So habe jetzt erst mal auf 0.6.5 downgegraded.


Jetzt bleibt nur noch die Fehlermeldung:

Kann die komponentenklasse TLTCPComponent nicht finden
Sie ist nicht mittels RegisterClass registriert und keine lfm wurde gefunden.
sebi099
 
Beiträge: 3
Registriert: 23. Mär 2015, 16:18

Beitragvon wp_xyz » 23. Mär 2015, 17:28 Re: Fehler bei der installation der Inet Komponente

Kann ich bestätigen, auch mit dem 1.4RC2 und lazarus trunk geht's nicht. Erst mit fpc-trunk lief's durch... Muss es denn unbedingt INet sein? Auf dem Gebiet gibt es ja zum Glück noch mehr.
wp_xyz
 
Beiträge: 2993
Registriert: 8. Apr 2011, 08:01

Beitragvon theo » 23. Mär 2015, 17:34 Re: Fehler bei der installation der Inet Komponente

Dann holst du dir am besten FPC Trunk http://wiki.lazarus.freepascal.org/Gett ... ngsversion
Oder du nimmst andere Networking Komponenten.
theo
 
Beiträge: 8193
Registriert: 11. Sep 2006, 18:01

• Themenende •

Zurück zu Windows



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

porpoises-institution
accuracy-worried