Programme für Mac OS X 10.3 kompilieren?

Antworten
jwdietrich
Beiträge: 142
Registriert: Mo 20. Okt 2008, 20:50
OS, Lazarus, FPC: Mac OS X 10.4-10.14, Windows 2000-8, SUSE, Ubuntu, Raspbian (L 2.0.6, FPC 3.0.4)
CPU-Target: PowerPC, Intel, ARM
Wohnort: Hattingen, NRW
Kontaktdaten:

Programme für Mac OS X 10.3 kompilieren?

Beitrag von jwdietrich »

Wie kann ich Programme so kompilieren, dass Sie auch unter Mac OS 10.3 (und nach Möglichkeit auch älteren Mac OS X - Versionen) laufen? Vorauszusetzen wäre das Carbon-Widgetset.

Stoney
Beiträge: 19
Registriert: Mo 14. Sep 2009, 15:16
OS, Lazarus, FPC: Mac OS (Lazarus 0.9.31, FPC 2.5.1)
CPU-Target: 32Bit & 64Bit
Wohnort: Königsbrunn
Kontaktdaten:

Re: Programme für Mac OS X 10.3 kompilieren?

Beitrag von Stoney »

Du benötigt maximal Mac OS X 10.5 (Leopard). Mac OS X 10.6 bringt keinen PowerPC-Support mehr mit sich, geschweige denn Mac OS X 10.3 - Support.
Dann muss du XCode installiert sein, inklusive der Mac OS X 10.3.9 SDK (kann man bei der Installation von XCode auswählen).

Folgendes muss an den Compiler übergeben werden:

Code: Alles auswählen

-XR/Developer/SDKs/MacOSX10.3.9.sdk/ -k-macosx_version_min -k10.3.9


Und dann läuft die Anwendung auf allen Mac OS X System ab 10.3.9.


Mit älteren Mac OS X Versionen sieht es recht schlecht aus, außer du hast die älteren Mac OS X - Versionen für die du dein Programm veröffentlichen willst selber, dann könntest du natürlich die darunter kompilieren und mit lipo die verschiedenen PowerPC-Versionen zusammenfügen. (Das ist aber ne recht größere Frickelei, vor allem, da bei einem Update oder einer neuen Version die gleiche Prozedur wieder von vorne ausgeführt werden muss.)

jwdietrich
Beiträge: 142
Registriert: Mo 20. Okt 2008, 20:50
OS, Lazarus, FPC: Mac OS X 10.4-10.14, Windows 2000-8, SUSE, Ubuntu, Raspbian (L 2.0.6, FPC 3.0.4)
CPU-Target: PowerPC, Intel, ARM
Wohnort: Hattingen, NRW
Kontaktdaten:

Re: Programme für Mac OS X 10.3 kompilieren?

Beitrag von jwdietrich »

Stoney hat geschrieben:Du benötigt maximal Mac OS X 10.5 (Leopard). Mac OS X 10.6 bringt keinen PowerPC-Support mehr mit sich, geschweige denn Mac OS X 10.3 - Support.

Maximal 10.5 auf der Entwicklermaschine? Wäre kein Problem, aber ist das für die Code-Generierung auch relevant (ich würde das Programm auf einer anderen Maschine mit Mac OS 10.3 testen)?

Stoney hat geschrieben:Und dann läuft die Anwendung auf allen Mac OS X System ab 10.3.9.

OK, werde das mal ausprobieren.

Stoney hat geschrieben:Mit älteren Mac OS X Versionen sieht es recht schlecht aus, außer du hast die älteren Mac OS X - Versionen für die du dein Programm veröffentlichen willst selber, dann könntest du natürlich die darunter kompilieren und mit lipo die verschiedenen PowerPC-Versionen zusammenfügen.

Kompatibilität mit 10.3 reicht vorerst.

Aus jeden Fall vielen Dank, ich freue mich schon aufs Testen!

jwdietrich
Beiträge: 142
Registriert: Mo 20. Okt 2008, 20:50
OS, Lazarus, FPC: Mac OS X 10.4-10.14, Windows 2000-8, SUSE, Ubuntu, Raspbian (L 2.0.6, FPC 3.0.4)
CPU-Target: PowerPC, Intel, ARM
Wohnort: Hattingen, NRW
Kontaktdaten:

Re: Programme für Mac OS X 10.3 kompilieren?

Beitrag von jwdietrich »

OK, die SDK für 10.3.9 habe ich.

Code: Alles auswählen

-XR/Developer/SDKs/MacOSX10.3.9.sdk/ -k-macosx_version_min -k10.3.9

Aber wo kann ich das denn übergeben? Als Direktive im Quelltext? Oder in einer der Compiler-Einstellungen? Aber in welcher? Oder sollte man das in einer Compiler-Konfigurationsdatei einbinden?

Ist der Quelltext dann noch portabel, spricht compilierbar für Linux und Windows? Oder gibt es eine Möglichkeit, die obigen Optionen nur beim Ziel Carbon einzubinden?

Nochmal vielen Dank!

jwdietrich
Beiträge: 142
Registriert: Mo 20. Okt 2008, 20:50
OS, Lazarus, FPC: Mac OS X 10.4-10.14, Windows 2000-8, SUSE, Ubuntu, Raspbian (L 2.0.6, FPC 3.0.4)
CPU-Target: PowerPC, Intel, ARM
Wohnort: Hattingen, NRW
Kontaktdaten:

Re: Programme für Mac OS X 10.3 kompilieren?

Beitrag von jwdietrich »

Gerade habe ich mal die naheliegende Compiler-Einstellung "Andere: Benutzerdefinierte Einstellungen" bzw. "Other: Custom options" versucht. Leider bekomme ich dann regelmäßig Link-Fehler, wenn ich das SDK für Mac OS 10.3.9 einbinde. Die Ausgabe der Konsole sieht eher so aus, als würde Lazarus Funktionen benutzen, die es unter OS 10.3 gar nicht gibt...

monta
Lazarusforum e. V.
Beiträge: 2842
Registriert: Sa 9. Sep 2006, 18:05
OS, Lazarus, FPC: Winux (L trunk FPC trunk)
CPU-Target: 64Bit
Wohnort: Dresden
Kontaktdaten:

Re: Programme für Mac OS X 10.3 kompilieren?

Beitrag von monta »

jwdietrich hat geschrieben:Ist der Quelltext dann noch portabel, spricht compilierbar für Linux und Windows? Oder gibt es eine Möglichkeit, die obigen Optionen nur beim Ziel Carbon einzubinden?


Müsste. Ich würde die Angabe in der fpc.cfg machen. Da du unter Linux/Windows ja ohnehin kein Carbon brauchst, sollte es sich Problemlos kompilieren lassen, vorrausgesetzt du nutzt in deinem Code keine Speziellen Dinge von MacOs.
Johannes

marcov
Beiträge: 1073
Registriert: Di 5. Aug 2008, 09:37
OS, Lazarus, FPC: Windows ,Linux,FreeBSD,Dos (L trunk FPC trunk)
CPU-Target: 32/64,PPC(+64), ARM
Wohnort: Eindhoven (Niederlande)

Re: Programme für Mac OS X 10.3 kompilieren?

Beitrag von marcov »

Mac OS X/x86 ist nur für 10.4 und höher. Mac OS X/PPC ist für 10.3 und höher

Es kann sein dass das ein Universaldatei die auch auf 10.3 funktioniert unmöglich macht.

Dass sind übrigens FPC Limitationen, ich weiß nicht ob Lazarus da eigene hat.

Antworten