Cross compilieren Linux x64 => aarch64

Für Installationen unter Linux-Systemen

Cross compilieren Linux x64 => aarch64

Beitragvon dash2055 » 6. Feb 2020, 12:06 Cross compilieren Linux x64 => aarch64

Nachtrag
Ich konnte das Compilieren von FPC auf dem RPI nun beheben,
fpcupdeluxe scheitert mit den aktuellen Trunk Versionen auf dem PI beim make.

Grund für den Abbruch war eine nicht deklarierte Funktion in der Datei /rtl/objpas/fgl.pp. Das Cross-Linker Problem ist mir damit nicht mehr so wichtig, wenn jemand dennoch die Lösung kennt, höre ich sie gerne :wink:

Hallo,
ich versuche zur Zeit von Linux x64 (Manjaro) nach aarch64 für den RPI4 zu compilieren, sind normale Terminal Programme die keinen Nutzen von der LCL machen, aber 24/7 laufen müssen, der PC wird da auf Dauer vom Strom her langsam zu teuer.
Hierfür habe ich zunächst mit Hilfe von fpcupdeluxe die aktuelle Trunk Versionen von FPC + Lazarus geladen, die cross Libs wurden scheinbar automatisch mit heruntergeladen, darauf habe ich den Projekt Einstellungen dann auch entsprechend verlinkt.

Bild

Das Linken scheitert jedoch.
Code: Alles auswählen
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /lib/crti.o when searching for /lib/crti.o
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: cannot find /lib/crti.o
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /lib//libpthread.so when searching for -lpthread
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /lib//libpthread.a when searching for -lpthread
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /usr/lib//libpthread.so when searching for -lpthread
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /usr/lib//libpthread.a when searching for -lpthread
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /lib//libdl.so when searching for -ldl
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /lib//libdl.a when searching for -ldl
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /usr/lib//libdl.so when searching for -ldl
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /usr/lib//libdl.a when searching for -ldl
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /lib//librt.so when searching for -lrt
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /lib//librt.a when searching for -lrt
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /usr/lib//librt.so when searching for -lrt
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /usr/lib//librt.a when searching for -lrt
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /lib//libc.so when searching for -lc
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /lib//libc.a when searching for -lc
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /usr/lib//libc.so when searching for -lc
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /usr/lib//libc.a when searching for -lc
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /lib//libc.so.6 when searching for libc.so.6
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /usr/lib//libc.so.6 when searching for libc.so.6
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /lib//libc_nonshared.a when searching for libc_nonshared.a
Error: /home/unwichtig/lazarus_trunk/cross/bin/aarch64-linux/aarch64-linux-gnu-ld: skipping incompatible /usr/lib//libc_nonshared.a when searching for libc_nonshared.a


Ein Versuch die entsprechenden Libs vom RPI zu kopieren (Manjaro ARM) scheitert genauso. fpcupdeluxe scheitert mit den aktuellen Trunk Versionen auf dem PI beim make.
Wäre nett, wenn mir da jemand unter die Arme greifen könnte.

Liebe Grüße!
dash2055
 
Beiträge: 1
Registriert: 6. Feb 2020, 11:49

• Themenende •

Zurück zu Linux



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

porpoises-institution
accuracy-worried