nach Update nur eine Version

Für Installationen unter Linux-Systemen
Antworten
Benutzeravatar
kralle
Lazarusforum e. V.
Beiträge: 673
Registriert: Mi 17. Mär 2010, 14:50
OS, Lazarus, FPC: Linux Mint 20 , FPC 3.3.1 , Lazarus 2.1.0 -Win10 & XE7Pro
CPU-Target: 64Bit
Wohnort: Bremerhaven
Kontaktdaten:

nach Update nur eine Version

Beitrag von kralle »

Moin,
nach einem Update unter Mint via SVN, werden mir beim Lazarus Start jetzt die alte und die neue Version angeboten.
Was muss ich machen, damit
a) mir nur noch die aktuelle Version angeboten wird?
b) nur noch die aktuelle Version auf der Platte ist?
c) beim nächsten Update, gleich a) und b) durch die Installationsroutine erledigt werden?

Gruß Heiko
Linux Mint 20, FPC-Version: 3.3.1 , Lazarus 2.1.0
+ Delphi XE7SP1

Mathias
Beiträge: 4909
Registriert: Do 2. Jan 2014, 17:21
OS, Lazarus, FPC: Linux (die neusten Trunc)
CPU-Target: 64Bit
Wohnort: Schweiz

Re: nach Update nur eine Version

Beitrag von Mathias »

Ich denke, du hattest in Vergangenheit mal dein Lazarus neu kompiliert.
Somit hast du das neu installierte und eines in dem Home-Ordner unter .Lazarus/bin.
Wen du die Version in ./Lazarus/bin entfernst/umbennenst, sollte der Fehler weg sein.

Natürlich kannst du deine aktuelle Version auch nach deinen Bedürfnissen neu kompilieren.
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot

Benutzeravatar
kralle
Lazarusforum e. V.
Beiträge: 673
Registriert: Mi 17. Mär 2010, 14:50
OS, Lazarus, FPC: Linux Mint 20 , FPC 3.3.1 , Lazarus 2.1.0 -Win10 & XE7Pro
CPU-Target: 64Bit
Wohnort: Bremerhaven
Kontaktdaten:

Re: nach Update nur eine Version

Beitrag von kralle »

Moin,

Sorry für die späte Reaktion.
Mathias hat geschrieben:Ich denke, du hattest in Vergangenheit mal dein Lazarus neu kompiliert.

Ja, ich habe ein Script, das mir die aktuelle Trunk zieht und installiert.
Muß ich also ins Script einbauen, das eine Version gelöscht wird oder kann ich bei der Installation irgendwelche Parameter angeben, damit ich immer nur eine Version habe? Meine Einstellungen sollten wenn möglich erhalten bleiben.

Gruß Heiko
Linux Mint 20, FPC-Version: 3.3.1 , Lazarus 2.1.0
+ Delphi XE7SP1

Antworten