Nachrichten-Fenster

Für Fragen rund um die Ide und zum Debugger
Antworten
Benutzeravatar
photor
Beiträge: 209
Registriert: Mo 24. Jan 2011, 21:38
OS, Lazarus, FPC: Arch Linux (L 2.0.10 FPC 3.2.0)
CPU-Target: 64Bit

Nachrichten-Fenster

Beitrag von photor »

Hallo Forum,

bin neu hier und neu bei Lazarus. Ich versuche, mit Lazarus wieder[1] in die Programmierung einzusteigen. Lazarus deshalb, weil es Delphi sehr ähnlich ist, und ich so lerne, mit Delphi umzugehen. Und vielleicht kann ich mein Projekt im Delphiumfeld weiterentwickeln.

Installiert habe ich Lazarus 0.9.28 mit FPC 2.4.0 unter Debian Squeeze. Bisher komme ich recht gut klar. :)

Aber seit neuestem wird das Nachrichtenfenster bei jedem Copilier-Vorgang in die obere linke Ecke gepackt (wobei es das Hauptfenster verdeckt). Das ist auf dauer nervig :shock: Zur Ursache kann ich nur sagen: ich habe an den Einstellungen gespielt, weil ich den Source-Editor anpassen wollte, weiß aber nicht genau, welche Einstellung dieses Verhalten bewirkt hat.

Ich habe schon versucht, im Einstellungsmenu, das Fenster an der Position zu fixieren, was leider nichts gebracht hat.

Das einzige, was bisher geholfen hat: unter KDE habe ich das Nachrichten-Fenster auf dem Desktop festgenagelt habe. Aber die wirkliche Lösung scheint das nicht zu sein. Irgendwo muss ich doch unter Lazarus dem Nachrichtenfenster sagen können, dass es schön unter dem Source-Editor bleibt, wenn es in den Vordergrund will.

Danke für jede Hilfe,

Photor


[1] früher in C, dann in Python programmiert. Alles unter Linux.

Benutzeravatar
theo
Beiträge: 8454
Registriert: Mo 11. Sep 2006, 19:01

Re: Nachrichten-Fenster

Beitrag von theo »

http://wiki.lazarus.freepascal.org/Manual_Docker
Damit kannst du das Message Window an den Editor docken.

Socke
Lazarusforum e. V.
Beiträge: 2789
Registriert: Di 22. Jul 2008, 19:27
OS, Lazarus, FPC: Lazarus: SVN; FPC: svn; Win 10/Linux/Raspbian/openSUSE
CPU-Target: 32bit x86 armhf
Wohnort: Köln
Kontaktdaten:

Re: Nachrichten-Fenster

Beitrag von Socke »

Ging es nicht eher um eine ungewollte Positionsänderung des Fensters? Bei mir (GNOME) bleibt es immer an der selben Stelle. Dass sich dieses Verhalten durch eine Einstellung umschalten lässt (zumindest kenne ich keine Option), halte ich für eher unwahrscheinlich; du kannst aber testweise deine Einstellungen in den den Auslieferungszustand bringen, indem du sie einfach löschst (Sicherheitskopie!; den Ort findet die Foren-/Websuche).
MfG Socke
Ein Gedicht braucht keinen Reim//Ich pack’ hier trotzdem einen rein

Bora4d
Beiträge: 290
Registriert: Mo 24. Dez 2007, 13:14
OS, Lazarus, FPC: WinXP-Pro-Sp3, Xubuntu 12.04, (Laz 1.1-SVN Mai2012, FPC 2.6.1 / 2.6.0-Linux)
CPU-Target: AMD64X2

Re: Nachrichten-Fenster

Beitrag von Bora4d »

Das hat mit Lazarus nicht zu tun, sondern KDE-Fenstermanager platziert die Fenster automatisch.

Benutzeravatar
photor
Beiträge: 209
Registriert: Mo 24. Jan 2011, 21:38
OS, Lazarus, FPC: Arch Linux (L 2.0.10 FPC 3.2.0)
CPU-Target: 64Bit

Re: Nachrichten-Fenster

Beitrag von photor »

Hallo Forum,

hm. Könnte schon sein, dass Bora4d recht hat und der Auslöser ein Upgrade von KDE-Komponenten war (mit einem normalen Debian-Upgrade).

Also warte ich erstmal, ob sich das Phänomen mit einem der nächsten Upgrades wieder behebt. Trotzdem erstmal Danke.

Ciao,

Photor

Antworten