SaveDialog dauert bis zu 18 Sekunden

Rund um die LCL und andere Komponenten
Antworten
siro
Beiträge: 386
Registriert: Di 23. Aug 2016, 14:25
OS, Lazarus, FPC: Windows 10
CPU-Target: 64Bit
Wohnort: Berlin

SaveDialog dauert bis zu 18 Sekunden

Beitrag von siro »

Windows 7 64 Bit
Lazarus: V1.8.2
FPC 3.0.4

Hallo zusammen,
ich wundere mich grad über die sehr lange Zeit zum Darstellen/Öffnen eines SaveDialogs.
Das dauert bei mir bis zu 18 Sekunden habe ich grade gestoppt.
Ist das normal ?

if NOT SaveDialog.Execute then exit;

Siro
Grüße von Siro
Bevor ich "C" ertragen muß, nehm ich lieber Lazarus...

charlytango
Beiträge: 193
Registriert: Sa 12. Sep 2015, 12:10
OS, Lazarus, FPC: Laz 2.0fixes FPC 3.2fixes
CPU-Target: Win 32Bit, 64bit
Wohnort: Wien

Re: SaveDialog dauert bis zu 18 Sekunden

Beitrag von charlytango »

Das langsame Öffnen eines OpenDialogs bzw eines SaveDialogs kenne ich durchaus, wenn man das Programm aus der IDE heraus startet.
Im Echtbetrieb ist alles normal flott. Früher ging der OpenDialog bei mir aus der IDE gar nicht, mittlerweile ist er langsam aber funktioniert.

Das nervt zwar etwas, nur habe ich das als Reibungsverlust gebucht. Würde mich aber auch freuen wenn das mal flotter ginge :)

martin_frb
Beiträge: 482
Registriert: Mi 25. Mär 2009, 21:12
OS, Lazarus, FPC: Laz trunk / fpc latest release / Win and other
CPU-Target: mostly 32 bit

Re: SaveDialog dauert bis zu 18 Sekunden

Beitrag von martin_frb »

Nicht getestet, aber probier das mal: http://wiki.lazarus.freepascal.org/GDB_ ... ed_working

Der dialog laedt dutzende DLL. Und gdb versucht fuer alle dll debug info zu finden.

siro
Beiträge: 386
Registriert: Di 23. Aug 2016, 14:25
OS, Lazarus, FPC: Windows 10
CPU-Target: 64Bit
Wohnort: Berlin

Re: SaveDialog dauert bis zu 18 Sekunden

Beitrag von siro »

Oh supi, vielen Dank euch Beiden für die Info.

Tatsächlich, wenn ich die .exe direkt starte, also ohne IDE, geht es sofort.

Dann ist das auch okay für mich, da hab ich kein Problem damit....

Die Debugoption hab ich jetzt zwar nicht gefunden, vermutlich wegen V1.8.2
Aber mein Problem würde ich mal assl gelöst bezeichen.

Habt ein schönes Wochende
Siro
Grüße von Siro
Bevor ich "C" ertragen muß, nehm ich lieber Lazarus...

martin_frb
Beiträge: 482
Registriert: Mi 25. Mär 2009, 21:12
OS, Lazarus, FPC: Laz trunk / fpc latest release / Win and other
CPU-Target: mostly 32 bit

Re: SaveDialog dauert bis zu 18 Sekunden

Beitrag von martin_frb »

Die Option "DisableLoadSymbolsForLibraries" existiert seit 1.2.4, also auch in 1.8.2

siro
Beiträge: 386
Registriert: Di 23. Aug 2016, 14:25
OS, Lazarus, FPC: Windows 10
CPU-Target: 64Bit
Wohnort: Berlin

Re: SaveDialog dauert bis zu 18 Sekunden

Beitrag von siro »

Guten Morgen Martin,
ja Du hast recht, die Option existiert,
ich habe am falschen Ort gesucht, nämlich in den Project Properties
die Option befindet sich aber in der IDE Einstellung.
Menüpunkt: Werkzeuge / Einstellungen / Debugger

Danke Dir
Siro
Grüße von Siro
Bevor ich "C" ertragen muß, nehm ich lieber Lazarus...

wp_xyz
Beiträge: 3271
Registriert: Fr 8. Apr 2011, 09:01

Re: SaveDialog dauert bis zu 18 Sekunden

Beitrag von wp_xyz »

Ich merke bei gesetztem "DisableLoadSymbolsForLibraries" keine Beschleunigung in der Zeit, bis der Dateidialog fertig geladen ist.

siro
Beiträge: 386
Registriert: Di 23. Aug 2016, 14:25
OS, Lazarus, FPC: Windows 10
CPU-Target: 64Bit
Wohnort: Berlin

Re: SaveDialog dauert bis zu 18 Sekunden

Beitrag von siro »

wp_xyz hat geschrieben:Ich merke bei gesetztem "DisableLoadSymbolsForLibraries" keine Beschleunigung in der Zeit, bis der Dateidialog fertig geladen ist.


Ich konnte es jetzt erst ausprobieren auf dem Firmen PC
und muss sagen: Jo, stimmt, wie bei wp_xyz, das ändert garnichts, ob ich die Option ein oder ausschalte.

Erstaunlicherweise habe ich das Problem zu Hause auf meinem Laptop mit Windows 8.1 garnicht
und auf dem Win10 Rechner auch nicht.
Mal wieder nur auf dem Firmenrechner mit Windows 7

Aber es ist wie erwähnt, NUR wenn das Program von der IDE aus gestartet wird.
Die EXE geht einwandfrei.
Grüße von Siro
Bevor ich "C" ertragen muß, nehm ich lieber Lazarus...

Antworten